×
请在电脑浏览器上访问
https://web.gstarcad.com/sharedLibrary/

产品支持

您可以阅览产品的相关CAD文档和视频教程等内容,以便于更好的使用浩辰CAD系列软件。

上千个CAD坐标手动输入?NO!快来试试CAD坐标批量导入!

2022-08-10 1460 CAD坐标  

CAD坐标是由X、Y、Z三个轴组成,其数值代表原点的距离。传统手动输入坐标,适用于数据较少的情况。尤其是对于勘测行业设计师而言,面对上千个测量坐标,手动一一输入、确认数据实在太低效!浩辰CAD针对上述情况,提供了多种方法来实现CAD坐标数据的批量导入。今天小编给大家演示一下,如何将EXCEL、TXT等常见文件中的坐标数据一键导入浩辰CAD,让你不再焦虑,准点下班!


1. EXCEL导入CAD

首先,将准备好的坐标及高程导入到Excel中。

上千个CAD坐标手动输入?NO!快来试试CAD坐标批量导入!

新建E列为展点划线,新建F列为注释。在E列输入公式【 ="line"&B2&","&C2】,在F列输入公式【="-text j ml"&B2&","&C2&""&5&"0 A"&A2&D2】。选中E2和F2列,在右下角光标变成十字时下拉,将E列和F列进行充填序列。

上千个CAD坐标手动输入?NO!快来试试CAD坐标批量导入!

打开浩辰CAD,复制E列数据导入CAD命令行,即可生成的图形文件。若不显示图形文件,双击滚轮即可。

上千个CAD坐标手动输入?NO!快来试试CAD坐标批量导入!

最后,复制F列数据粘贴至CAD命令行,生成的图形文件上会显示坐标信息。

上千个CAD坐标手动输入?NO!快来试试CAD坐标批量导入!

2. TXT导入CAD

首先,绘制一个简单图形,再使用浩辰CAD坐标输出功能,将坐标提取到TXT文档中。操作步骤为:点击【扩展工具】—【坐标工具】—【坐标输出】。

上千个CAD坐标手动输入?NO!快来试试CAD坐标批量导入!

再将TXT文档的文本格式进行修改,其中XY之间使用英文逗号进行隔开。

上千个CAD坐标手动输入?NO!快来试试CAD坐标批量导入!

打开浩辰CAD,在命令行输入快捷键【POINT】,选择【多个(M)】,将TXT文件内的坐标复制粘贴到命令行即可。若导入的点无法查看清楚,可在【格式】—【点样式】中修改点样式。最后,可使用多段线【PLINE】连接各点,与原图形进行对比查看。

上千个CAD坐标手动输入?NO!快来试试CAD坐标批量导入!

以上是浩辰CAD软件中批量导入CAD坐标的两种高手技巧,你学会了嘛?大家赶紧下载浩辰CAD软件试试吧!

Copyright © 1992-2021 苏州浩辰软件股份有限公司 版权所有 苏ICP备12077906号 增值电信业务经营许可证: 苏B2-20210241